• This section is "bound" to the Resources page. Once you've submitted a new mod to the resources, a new discussion about your mod will be automatically generated and posted in this section. That means, you can't create a new thread by hand in here.
  • The move of Eco-Mods.com has taken place and the merge of our old officials forums is currently ongoing, read more here.
Extra start stars

Extra start stars 1.0.0

No permission to download

hami

Coal
Messages
18
Reaction score
2
I found a bug. If u change to config to 1 you get no bonus star (only the star u have without the mod), but if u change to 2 you get 2 extra stars (sum of 3).
 

Omron360

Coal
Messages
18
Reaction score
4
I wouldn't say that it is a bug. After first load the config is written with the value of 1. And you'll find a subdirectory named users whre your userid is saved. Next time you login you don't get additional stars. If you delete the file you'll get the value of stars of the config file.
@mampf:
Maybe it's a good idea to rollout a config with the value 1 and the user can change that value. But I've no problem with the mod so far.
 

hami

Coal
Messages
18
Reaction score
2
I wouldn't say that it is a bug. After first load the config is written with the value of 1. And you'll find a subdirectory named users whre your userid is saved. Next time you login you don't get additional stars. If you delete the file you'll get the value of stars of the config file.
@mampf:
Maybe it's a good idea to rollout a config with the value 1 and the user can change that value. But I've no problem with the mod so far.
that would mean i have to delete it for every new player that will join?
 

Omron360

Coal
Messages
18
Reaction score
4
No, if you changed the config then every new User will get the quantity of stars. All other (you too) get no additonal stars except you delete the user config. So, if you are the only user at this time then write down that name. If you want additional stars then delete your file and you'll get it every time. But be careful because for every star you need points for the next level. And if you give more stars it takes more time.
 
OP
mampf

mampf

Moderator
Mod Dev
Eco-Mods.com Founder
Messages
115
Reaction score
72
I'm a little bit confused ;)

But if you know how it's working that's fine :p - Maybe you know it better than me ;)

My idea how it should work:

The mod adds the amount of stars from the config file to a player on the first join after the mod is installed.
This happens exactly only one time (except you delete the stored files from the mod folder).
If you set 1 in the config file you get 2 stars, because you got 1 eco default star and 1 additional.

If you modify the value in the config after the star was added to the player, nothing will change to the players, who already got anything.
 

hami

Coal
Messages
18
Reaction score
2
yes i understand that but new players also only get 1 star AFTER the mod is installed?!
 

Omron360

Coal
Messages
18
Reaction score
4
@hami
No. You must edit the value of the config then new player will get this amount of stars.

@mampf
You're description is absolutely correct.
 
Messages
13
Reaction score
0
i have the asphalt kit, i have also installed other mods dependent on asphalt. but for some reason its not giving stars. i put the extrastartbars folder in the mod folder of the server, i rally want this to work, it seems temperamental one time i got 3 stars, and 3 times none. and only a few times i got 1
 
Last edited:
Messages
13
Reaction score
0
i had regenerated worlds. and i have a following of around 30 people logged on after the mod. on a brand new world. not a single one got an extra star
 

Omron360

Coal
Messages
18
Reaction score
4
@CaptainCaveman Sorry, it's really difficult to solve your problem. Ok, then from the begining. I have a folder named "ExtraStartStars" in mods wherein the ExtraStartStars.dll is placed. Second is the config.json. I think you has one from a server start. Inside there is the entry
JSON:
{
    "SpecialityPoints":5
}
with the digit you want to give once. If there is a directory users then delete it for a test.
After all restart the server and try once more.
 
Last edited:
Top Bottom